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Chapter 1. #####

### BibleTime
BibleTime — ## ###### ### ######## ###### # ########## ###### ##### ####### # ###.
###### ###### ##'### ##### ####### ###### # ############ ## #########. ### ########### ##
########## SWORD [http://www.crosswire.org/sword/] , ### ########## ##### ################
### BibleTime, #### ## ######## ########## ######, ##### ####. SWORD # ############
######### Crosswire Bible Society [http://www.crosswire.org].

BibleTime ########### ### ############ # #######, ############ # ###### # ########,
############# ######## SWORD. ##### ########## ### ############ ####### ########## #####
###### #  ####### ########## [http://www.crosswire.org/sword/develop/index.jsp] ####### SWORD,
Crosswire Bible Society.

######## #####

###### 280 ########## 50-## ###### ######## # Crosswire Bible Society [http://www.crosswire.org].
#########:

###### ###### ##### ######, # ######'######## ######, ######
## ##### #######, ######### ##/## ####### # ######.
###### ######## ######## ###### ## ######### # ####
## #### ####### ######, ### # ###### ######, ####
## Codex Leningradensis ("WLC", #####) # ###########
("LXX", ########). ## ############### ###### #
########## ####### SWORD.

##### ######## ##### ######### "############ ######",
"##### ####" # "##### ######: ##### ###### ######"

######### ######## ######### ######### # #### #######, ####
## "####### ## ######" ##### #####, ######## #####
##### ## "######## ## #######" ######." ## #########
########## ######### ## ######  ########## ####
######## ####### ## ######## ######.

####### ####### ###### ##### ####### ## ####### ###### ## #####
######. ######## ###### ######### ####### ###### ##
######### ##### ## ########.

#########/######## ######## ######### #########: #### ##############
####### ######### ## ########## ##########
######## ############. ######## ######## #########
################# ######### ####### #######,
######## ######### ####### #######, ############
### ######### ####### ########### #### ########
1913 ####, ######### ###### ####.

# ######## ##### ############, ### BibleTime #### ############# ## ###############.
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#####

#########
#### ####### ####### # ####, ### ####### ###### ## ########## ##### ##### # ## ###########
# ###. ## ######## ####### ## #######, ###### ######## # ### ##### ####### ## ####### #
########## ########## # #########. ## #######, ### #### #########, ## ### — ####### #### ####.

##### ##### ####### ## ### ########## ######## #####, ### ###### ######, #
##### ##### ##### ## ## #### ##########.

—##### 1:17, NASB

########## ### ###, ############## ## ########.
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Chapter 2. Starting BibleTime
How to start BibleTime

Starting BibleTime
BibleTime — ## ########### ####, ############ ## ##########. ## ###### ######### BibleTime
## #### '####' ## ######### ##### ######:

BibleTime ##### #### #### ######### ## ########## ##### #########. ### ######### BibleTime,
######### ##### ######### ## #######:

bibletime

############ #######
From a terminal you can use BibleTime to open a random verse in the default bible:

bibletime --open-default-bible "<random>"

To open at a given passage like John 3:16, use:

bibletime --open-default-bible "John 3:16"

You can also use booknames in your current bookname language.

Starting BibleTime for the first time
If you are starting BibleTime for the first time, you will want to configure the following options, available
under the Settings menu bar.

######### ######### ###### Modifies your Bookshelf. This dialog lets
you modify your Bookshelf, add or delete
works from your system. It will only be
shown if no default Bookshelf can be found.
Please see The Bookshelf Manager section
for further details. If you start off with an
empty Bookshelf, it will be helpful to install
at least one Bible, Commentary, Lexicon
and one Book to get to know BibleTime's
basic features quickly. You will be presented
with a list of works that are available
from the Crosswire Bible Society and other
repositories;

Configure BibleTime dialog Customizes BibleTime.This dialog lets you
adapt BibleTime to your needs. Please see the
detailed description of this dialog.
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Chapter 3. ###### ########

##### ########
### ## ######## ####### ##### BibleTime :

## ###### ##### ######## ##### ####### ##########. ###### #### ##### ################
### ######### ############ ##### ## ####### ######## ######, # ## ######### #######
######## ## ###### ######## ###### ##########. ######## ####### "Mag" ### ######### #######
################ ### ###### ########## ##########, ### ######### # #########. #########,
#### ## ######## ######### #### ## ###### #######, ###### ####### ######### ##### #######.
###### ####### ### ### ####### ###### ## ######## #######, # #### # ####### #### — ## #####,
## ## ###### #### ######## ######.

####### ##### ######### ## ######## ###### ###### ########## ######.

####### ##### ########## BibleTime

######## ######

## ######### ###### ########## ### ########### ######, ############## ## ########### ##
#####. # ##### ##### # ######### ### ###### "########". ### ## ###### ######### #### ######
######## ## ########## ## ### ######.
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###### ########

######## ######

### ######## ###### ## ######### ###### ### #######, ###### ##### ######## ##### #######
#### ## ######### ######### (######, #########, #########, #####, ###########, ## ########),
### ######## #### #####. ##### ###### ##### ######## ## ##### ## #####, ### ######## ## ###
#######. # ####### ######### #'####### ##### ### #######.

#### ## ####### ###### ###### # ####### ######## ##### ###### # ######, #### ## #######, ##
###### ############### #####. ###### ######### ##### ####### #### ## ######### #####/######
(######### ######### ## ####) ## ########### ## ## ######## ######. ########## ## ## ######,
#### ## ####### ########, # #### #### ######## ### ####### # ######### #####. ## ##### ######
########### ######### ## #### # ###### ##### #######, ##### #### #### ####### # ####### #####.

######### ########## ### #####

#### ######## ############# #### ## ####### ######, ## #'####### #### # ###########
########, ## ##### ######## ## ###### ######. "### ######" ######### ##### # #######
######### ####### ########## ### ######## ###### "############ ######" ######### ########
######### ##### ### ############ ##########, ## ## ###### ###### #### #############
### ####### ## ######. ### ######### ########## ########## ### ########### ######, ####
#####, ########## ########  ############ ####### [http://www.crosswire.org/sword/modules/
aboutlocked.jsp] ## ######## Crosswire Bible Society.

##### # ######

## ###### ######## ##### # ######, ######### ###### ####### #### ## ## ####### # ####### #####
"##### # ######". ########## Shift # ########## ## #### ######, ## ###### ####### ###### ######.
##### ######### ## # ###, ### ######## ######### ##### ######. ## ###### ###### # #### ###
##########. ###### #### ###### ####### ###### ##### ###### # ####### ##### # #######.

###### # ##########

Tip

########### & ########## ## ######
######## ###### ####### #### ## ######### ####### ######### ###### ## ######## #####
"######## #### ####"2, ### ######## #### ####### ########. ## ###### ###############
######## ####### ############# ### ############# ######## ## ##### # ##### #######, ###
########### ###### # #### ########, # ##### ### ############ ####### ### ######

## ##### ###### ########### ######## ### ##### #####, ### ############ ########, ###
########## ####. ### ##### ######### ########## #### #### ########, ## ####### #### ##
######## ##### "####### ########". ## ####### ######### ##### ### ########## ########
########. ########## ##### ########### ########.

## ##### ###### ######## ###### ####### #### ## ##### # #########, ### ####### ## ##### ##
#####.

(#############) ####
## ######## ####### # ###### ######## ##### ##### BibleTime # #### ########. #####, ####
######### #### ########### ### ####-#### ####### # ########## ########### (#########,
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###### ########

####### #######), ## ######### ########## #### ############ # #######, # ## # ###### ######.
###### #########.

#########

######### — ## #####, ## ############ ######## ###### # BibleTime. ### ## ###### ##########
###### # ######### #######, ###### ##, ###### # ### # ###### ######### #### ######## # ######
######### ########## (### #####).

####### ######

## ## ### ######, ## ###### ######## ##### ### #######, ###### ########## ## ## ###### ##
######### ######. # #### ######### ########### ##### ### #######. ##### ##### ### ######
#######. ### ## ###### ###### ####### ### ######### # ######, ## #### ###'###### ## #####
#######, # ##### ###### #######, ####### ## ###, ### ## ###### ## ##### ########.

############

## ##### ### ####### ##### ##### ########### ####### #####, ## ####. ####### ########,
########## Shift + Down. ## ###### ######### ######### ########, ########## ###### ##### Shift
+ Down. ### ########### ########, ######### ######. ### ######### ######## # ###########
#########, ##### ######### ######. ### ########### ########, ## ########## # ###### ########,
######### Shift + Up ####, ### ###### #####. ########## ####-##### ###### #######, ## #####
######### ##### ######## ########.

Read window placement

Of course, you can open multiple works at the same time. There are several possibilities for arranging the
read windows on the desk. Please have a look at the entry Window in the main menu. There you can see
that you can either control the placement of the read windows completely yourself, or have BibleTime
handle the placement automatically. To achieve this, you have to select one of the automatic placement
modes available at Window → Arrangement mode. Just try it out, it's simple and works.

########### ######## #########

To be able to store your own comments about parts of the Bible, you have install a certain work from
the library of the Crosswire Bible Society [http://www.crosswire.org]. This work is called "Personal
commentary".

Open the personal commentary by clicking on its symbol in the Bookshelf with a left mouse button. You
can edit this commentary by just clicking on any verse. A dialog opens which allows you to add or edit
text for that verse.

Tip

If Edit this work is deactivated, please check if you have write permission for the files of the
personal commentary.

Tip

Drag & drop works here. Drop a verse reference and the text of the verse will be inserted.
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###### ########

##### # ######

##### ###### # ########## ##### #######
You can look for a word or phrase in the open read window (e.g. the chapter of a bible that you're reading)
just like you are used to from other programs. This function can be reached either by clicking with the
right mouse button and selecting Find..., or by using the shortcut CtrlF. Read on to learn how you can
search in entire works.

###### ## ########### ##### ######
You can search in a work by clicking with the right mouse button on its symbol in the Bookshelf and
selecting Search in work(s). By holding Shift or Ctrl and clicking on other work's names you can select
more than one. Then follow the same procedure to open the search dialog. You will be searching in all
of these works at the same time.

You can also access the search dialog by clicking on Search from the main menu, and selecting the
appropriate entry.

##### ########## ######### ##### — ## ######### ## ###### ###### # ########## ##### #######.

############ ######
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###### ########

##### ######

At the top of the options tab you will find Choose(works). If you would like to search in multiple works,
click on this button and you will be offered a menu where you can select the works you want to search in.

############ ######## ######

You can narrow the scope of your search to certain parts of the Bible by selecting one of the predefined
scopes from the list in Search scope. You can define your own search ranges by clicking the Setup ranges
button.

##### ## ######## ########## ######

Enter the search phrase separated by spaces. By default the search function will return results that match
all the words. If you want to find any of the words entered, select the Some words button. If you want
to perform a more complex search, select the Free button. You can see examples of searches by clicking
on full syntax.

You can use wildcards: '*' matches any number of characters, while '?' will match any single character.
The use of parenthesis allows you to group your search terms, e.g. '(Jesus OR spirit) AND God'.

To search text other than the main text, enter the text type followed by ':', and then the search term. Refer
to the table below for examples.

######## #### ######:

Table 3.1. #### ######

####### ######## #######

#########: ##### # ########### #########:####

#######: ##### # ######## #######:######

#######: ##### ####### ####### #######:G535

####: ##### ##### ########## ####:N-GSM

Tip

You can right click on an installed work and select About to find which of the above search criteria
may work for you. Not all works have the built in features for performing this type of search.

BibleTime ############ ######## ####### Lucene ### ########## ##### #######. ### ### ######
########## #######, # ## ###### ######### ###### ### ## ###:  http://lucene.apache.org/java/docs/
index.html [http://lucene.apache.org/java/docs/index.html].

########## ######
Here you can see how many instances of the search string were found, sorted by works. Clicking on a
work with the right mouse button allows you to copy, save, or print all verses that were found in a certain
work at once. This also works when you click on one or more of the references to copy, save or print them.
Clicking on a particular reference opens that verse up in context in the preview window below.

Tip

Drag a reference and drop it on a work symbol on the Bookshelf to open the work at that verse
in a new read window.
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###### ########

Tip

########### ######### ## ###### #### # ######## ##### #######, # #### ####### ##
##### #####.

Tip

####### ######### ## ########### ## ## ######## ######, ### ######## ########.

###### ########### ######

Click on Search analysis to open the search analysis display. This gives a simple graphic analysis of the
number of instances the search string was found in each book of the Bible, and you can also save the
analysis.

######### ######### ######
The Bookshelf Manager is a tool to manage your Bookshelf. You can install new works to your Bookshelf,
and update or remove existing works from your Bookshelf. Access it by clicking Settings → Bookshelf
Manager in the main menu.

############ #######
## ######### ##### ###### ## ###### ###'######## ## ####### ####### (## ###########
'###########') ## ######### ####, ### ###### ####### ## #### ####### ######## ######. ##
########## ###### #### ########## (#########, SWORD CD), ### ########### (#########,
########-####### ####### SWORD Crosswire, ### ##### ####, ## ######## ###### SWORD).
BibleTime ########### ############## ####### ########## ######### # ######## # ### ######.

To begin the installation process, select one or more libraries that you want to install works from. Then
click on the Next button. Then select one or more languages and click the Next button. You will see a list
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###### ########

of categories. Double-click on a category to see works for that category. Select one or more works and
then click on the Install Works. After the works are installed, click on the Finish.

######### #######
If there are any works that can be updated, they will be shown. Select one or more work and click the
Update Works. After the works are updated, click on the Finish.

######### #######
This facility allows you to delete one or more of the works from your Bookshelf too free up disk space.
Simply choose the works` and click on the Remove works button.

####### # ####
In many places, you can open a context menu by clicking with the right mouse button. Depending on
context, it will allow you to Select, Copy (to clipboard), Save or Print text. This works for example in the
read windows, when you click on the normal text or the verse reference, or in the search result page when
you click on a work or one or more verse references. It is pretty straightforward, so just try it out.

#### ## BibleTime # ###### ####### # ########### ## #######. #### ## ######### ########,
### ###########, ## ####### ##### ## ###### BibleTime, ## ########## ############### ####
## ####### ###########, ### ########### # ##### ####### ### ############ #########, # ##
######### # BibleTime #############.
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Chapter 4. ############ BibleTime
# ##### ####### ## ######## ##### ############ BibleTime, #### ##### ###### # #######
############ # ######### ####.

###### ############ BibleTime
############## ######### BibleTime #### #### ############ ######## ######### ####### ###
##### ######. ## ###### ######## ###### ## ########### ##### ############, ######## #####
############ ############ BibleTime.

#######

######### ### ####### ##### ###########. ####### #### ## ##### #########:

• ########## ######## ### #######

####### ###### ########## ############ ###### (#######, ###### ####.). ######## #####
######### #######. #### ## ######## #### ## ###, ## ######## ############ ## ###### ######.

#########

###### #######, ############ SWORD ######## ####### ##### ###### #### ###########
# BibleTime. ## ####### ############### ##### # ########### #####. # ### ##### #
########## ####### ########## ######, ### #### ###############, #### # ######### ## #######
###### ########## #####. #######: ########## ###### ################ ### ###### ######
########### ######## # ######. #### ## ######## ## ### #########, ###### ###### #####
######## ###### # ############# ## ########### #######, ### ## #######. ## #########
######### ######## ##### ######## ######### ######## ######.

####

### ## ###### #######, ### #### #### ############### ### #### ######### ####. ########## ##
## #### ##### ####, #### #### ########, ## ## ######## #### ## #####.

######## BibleTime ############ ####### ##### ########## #######. ## ############ ##
###### ############# ### #####. ##### #### ##########, ### ########## ###### ############
#########, ## ## ######### ##### ######## ####### ############## ##### ### ###### ####.
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############ BibleTime

##### ######### - ######

BibleTime ##### #### ############### ### ############ ######. ####, #### ###### ### ###
###### ########### #########, ### ###### ## ######## ######. #### ###### ########### #### #
####### ##### ###### ####### (??????), ## ####### #######, ## ## ######, ## ########### #####
####### ## ####### ########, ################ # ##### ######.

### ######### ##, ######## #### ##### ###### # ######### ####. ########## #########
############### ############## #####. ##### ####### #####. #########, #####, ## #########
###### ###, ########### Code2000. #### ##### ############ ##### ## #### ######## ####### ###
######, ######### ########## ####### ########### ### #### ####.

############ #######

######## ######## ## ############ ####### ######## ## ##### ####### #########. ###
######### ########## ########## ## ###### ########## ##  Unicode HOWTO [http://
www.linux.org/docs/ldp/howto/Unicode-HOWTO-2.html].

###### ###### #### ########### # ######### ######:

• ### ########### *nix.

• ####### ########### ###### ############.

• ## ##### ####'##### ########### Microsoft Windows®.
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############ BibleTime

• ######## #######, #########, ######### # Adobe, ## Bitstream.

• ###### ######## #######.

###### Unicode ########### ###### ########, ### #### ######, ## ##### # ### ####### ########
###########. ##### ## ######### ####### ## ####### # #### ### #######, ######### # #########
Unicode, #### ## ###### ############### ##### ###### ### ###### ###.

Table 4.1. ######## ######

Code2000 [http://code2000.net/CODE2000.ZIP] ######, ######### ############ #####
Unicode, ## ####### ####### ###### ########.

SIL ######## ###### [http://scripts.sil.org/cms/
scripts/page.php?
site_id=nrsi&cat_id=FontDownloads]

######## ###### Unicode ### Summer
######### M###########.

FreeFont [http://www.nongnu.org/freefont/] #### ########## ####### ####### Unicode.

Crosswire ####### ####### [ftp://
ftp.crosswire.org/pub/sword/iso/latest/FONTS/]

######## ####### ######## # FTP-#####
Crosswire Bible Society.

Bitstream CyberBit [http://aol-4.vo.llnwd.net/pub/
communicator/extras/fonts/windows/]

####### ##### #### ######## Unicode, ### ####
########### BibleTime #-## #### #######.

Clearlyu ####### # ##### ############. #######
###########, #######, #########, #######.

Caslon, Monospace, Cupola, Caliban [http://
fontforge.sourceforge.net/sfds/]

######## #########, ###. ########## ## #####.

# ###### # ###### ######## ####### Unicode, #### ## Christoph Singer ( ########### ######
Unicode TrueType # ######### [http://www.slovo.info/unifonts.htm]) ## Alan Wood (  #########
######## Unicode ## ###### Unicode, ### ## ########### [http://www.alanwood.net/unicode/
fontsbyrange.html]).

######

###### (###### ###### ## ########## ########) — ## ########## ####### ########, ### #####
############### ####### ####### #### ## #######. ##### ####### BibleTime ##### #######
######### ###### (###### ####### ###. ######## ###### ). ######### BibleTime ###### ######
#### ########## ########## ########. ## ###### ####### ### ######## ####### ## #######, ###
### ######## #########.
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http://www.alanwood.net/unicode/fontsbyrange.html


############ BibleTime

# ############ ######## F2, Bible Study ########### ### ########## #####, ########## CTRL+2.
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Chapter 5. #########
######### ## ####### ####

# ##### ####### ## ###### ###### ######### #### #### ####### # ######### #### BibleTime.
#### ############ ###, ## #### #'######### # BibleTime # ##### ###########, ############
### ######## ####### ####, ## ##### #### ########. ## ##### ###### ######## ##### #######
########; ###### ####### #### ####### ##### ###### ###### #######.

####

#### 

→

 ######## ####

Open work. This will give you a menu that
will allow you to open installed books.

#### 

→

 ##### (Ctrl+Q)

Closes BibleTime. BibleTime will ask you if
you want to write unsaved changes to disk.

######

###### 

→

 ############# ##### (F5)

######### ############# #####.
########## ### ########, ###
############ BibleTime #####.

###### 

→

 ######## ######

Toggles display of the Bookshelf. Toggle this
setting to turn the Bookshelf on the left pane
on or off. This can be handy if you need more
space for the Mag.

###### 

→

 ######## ########

Toggles display of the Bookmarks. Toggle
this setting to turn the Bookmarks on the left
pane on or off. This can be handy if you need
more space for the Mag.

###### 

→

 ######## ####

Toggles display of the Mag(nifying glass).
Toggle this setting to turn the Mag on the left
pane on or off.

###### 

→

 ######## ########## ########
#########

Toggles viewing of additional works Toggle
this setting to allow you to view additional
works in parallel to your current open books.

###### → ###### ############ → ######## #######
(F6)

Toggles Main Toolbar display. Toggle this
setting to turn the main toolbar on or off.

###### → ###### ############ → ########
########

Toggles Navigation in works. Toggle this
setting to add or remove the navigation
combo box in works. This can be handy to
view the full toolbar in the open works
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#########

###### → ###### ############ → ######## ##### Toggles Toolbars in works. Toggle this
setting to add or remove the works icons in
the open works.

###### → ###### ############ → ########
###########

Toggles tools in works. Toggle this setting
to add or remove the tools icons in the open
works.

###### → ###### ############ → ######## ###### Toggles format. Toggle this setting when
editing HTML in Personal Commentaries. It
will add or remove the formatting toolbar.

###### → ###### ############ → ######## ######
############ # ###### ######

Toggles toolbars in works. Toggle this setting
to add or remove the complete toolbar in open
works.

#####

##### 

→

 ##### # ########### ###### (Ctrl
+Alt+F)

Opens the Search Dialog to search in the
standard Bible only. More works can be
added in the Search Dialog. A more detailed
search description can be found in the
Searching in works section.

##### 

→

 ##### # ########## ######(##) (Ctrl
+O)

Opens the Search Dialog to search in all open
works. Works can be added or removed in
the Search Dialog. A more detailed search
description can be found in the Searching in
works section.

#####

##### 

→

 ####### ##### (Ctrl+W)

######## ####### #####.

##### 

→

 ####### ### (Ctrl+Alt+W)

######## ### ######## #####.

##### 

→

 ###### (Ctrl+J)

######## ### ######## #####.

##### 

→

 ########### (Ctrl+I)

########## ### ######## #####.

##### 

→

 ########### ##### ####### (Ctrl
+G)

########### ######## ########### ###
######## #####.

##### 

→

 ########### ###### #### (Ctrl+H)

########### ######## #############
### ######## #####.
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#########

##### → ##### ############ Controls the basic window arrangement
behaviour. In the opening context menu, you
can either specify that you want to take care
of the window arrangement yourself (Manual
mode), Tabbed, Auto-tile vertically, Auto-tile
horizontally, Auto-tile or Auto-cascade. Just
try them out!

##### → ######## ##### Directly saves the current session. This will
open a context menu where you can select
an existing session to save to. It will be
overwritten with your current session. See the
next item on how to save to a new session.

##### → ######## ## ##### ##### (Ctrl+Alt+S) Saves the current session under a new name.
This will ask for a new name to save the
session to.

##### → ########### ##### Loads an existing session. This will open
a context menu where you can select an
existing session to load.

##### → ######## ##### Deletes an existing session. This will open
a context menu where you can select an
existing session that should be deleted.

############

############ 

→

 ########### BibleTime

Opens BibleTime's main configuration
dialog. You can configure all kinds of nice
settings there to adapt BibleTime to your
needs. Please see the Configuring BibleTime
section for details.

############ 

→

 ######### ####### (F4)

Opens a dialog where you can change your
SWORD configuration and manage your
bookshelf. Please see the Bookshelf Manager
section for details.

#######

####### 

→

 ######## (F1)

######### BibleTime ###########
########### ## ####### #### #####.

####### 

→

 ######## ###### — ## (F2)

Opens a guide on how to study the Bible It
is the hope of the BibleTime team that this
HowTo will provoke the readers to study the
scriptures to see what they say. This particular
study guide has been chosen as it takes care
not to advocate any particular denominational
doctrine. We expect you to read and study the
scriptures to understand what they say. If you
start with the attitude that you want to have
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#########

the Lord sow his word in your heart He will
not disappoint you.

####### 

→

 ###### ### (F3)

Opens a helpful tip The Tip of the Day
provides a useful tip that will assist in the use
of BibleTime.

####### → ### Opens a window about BibleTime
project information contains information
about BibleTime software version, project
contributors, SWORD software version, Qt
software version and the license agreement.

######## #####
# ##### ####### ## ######## #### #########, ###'###### # ########## ########.

####### ###### ##### ######.

####### ##### ##### ######.

####### ########### ######.

####### ######### ######.

##### # ######## ######.

######## ############.

####### ############ ########.

####### ########## ########.

############# ######### ##### ##
######## ###### ######.

###### #####
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#########

####### ############ ########, ###
#######.

####### ########## ######## ###
#######.

###### #######
This is an index of all shortcuts and their corresponding description in the handbook. The shortcuts are
sorted (roughly) alphabetical. If you want to directly find out which shortcuts a certain menu item has,
you can either look at the entry itself in BibleTime (as it always shows the shortcut), or you can look it
in the Main Menu reference.

##### ####

Alt+Left Moves back in the history of read windows.

Alt+Right Moves forward in the history of read windows.

Ctrl+Alt+F Search → Search in default bible  equivalent; opens
the search dialog to search in the default bible.

Ctrl+Alt+G Window → Arrangement mode → Auto-tile
vertically equivalent; toggle automatic window
tiling.

Ctrl+Alt+H Window → Arrangement mode → Auto-tile
horizontally equivalent; toggle automatic window
tiling.

Ctrl+Alt+I Window → Arrangement mode → Auto-tile
equivalent; toggle automatic window tiling.

Ctrl+Alt+J Window → Arrangement mode → Auto-cascade
equivalent; toggle automatic window cascading.

Ctrl+Alt+M Window → Arrangement mode → Manual mode
equivalent; toggle manual window placement.

Ctrl+Alt+T Window → Arrangement mode → Tabbed
equivalent; organizes windows with tabs across the
top.

Ctrl+Alt+S Window → Save as new session  equivalent; saves
current layout as new session.

Ctrl+Alt+W Window → Close all  equivalent; closes all open
windows.

Ctrl+A ###### ###. ## ####### #### ##### # ##########
######.

Ctrl+C #########. ## ###### ######## ##### # #####
######.

Ctrl+F #####. ## ######## ########### ##### # ######
##### #######.

Ctrl+G Window → Tile vertically  equivalent.

Ctrl+H Window → Tile horizontally  equivalent.
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#########

##### ####

Ctrl+I Window → Tile  windows equivalent.

Ctrl+J Window → Cascade  windows equivalent.

Ctrl+L ####### #####. ###### ##### ## #### ######
####### ### ######## ######.

Ctrl+N Search with works of this window.

Ctrl+O Search → Search in open work(s)  equivalent; opens
the search dialog to search in all currently opened
works.

Ctrl+Q File → Quit  equivalent; closes BibleTime.

Ctrl+W ######## ####### #####.

F1 Help → Handbook equivalent; opens the handbook.

F2 Help → BibleStudy HowTo equivalent; opens the
BibleStudy HowTo.

F3 Help → Tip of the Day Opens a helpful tip to use
BibleTime.

F4 Settings → Bookshelf Manager  equivalent; opens
the Bookshelf Manager.

F8 View → Show Bookshelf  equivalent; toggles
display of the Bookshelf.

F9 View → Show mag  equivalent; toggles display of
the mag(nifying glass).

Shift+Down View → Auto scroll down

Shift+Up View → Auto scroll up

Space View → Auto scroll pause
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